Crosstool: Troubleshooting tips

Since I got my Tsunami board up and running, I decided to try building my own toolchain. Decided to go with Crosstool to build the toolchain. So far it’s been OK and can get it to toolchain to compile the Tsunami board kernel using the same gcc version as the CodeSourcery version. One thing it took quite a bit time to solve was how to fix is the following.

Problem:

building cross gdb

error: expat is missing or unusable.

Fix:

sudo apt-get install libexpat1-dev

 

Advertisements
This entry was posted in crosstool, Embedded, troubleshooting and tagged , , , , , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s